test online bacalaureat informatica varianta 2

bacalaureat informatica varianta 2

* Variabilele x şi y sunt tip int. Care dintre expresiile C/C++ de mai jos are valoarea 1 dacă şi numai dacă valorile întregi nenule memorate în variabilele x şi y sunt egale?
* Scrieţi ce se va afişa dacă se citesc, în această ordine, numerele: 17 22 13 101 2 7 5 0.
citeşte x (număr natural nenul)
┌cât timp x>0 execută
│ citeşte y (număr natural)
│┌dacă x>y atunci
││ scrie x%10
││altfel
││ scrie y%10
│└sf_daca
│x<-y
sf_cât timp
* Câte grafuri neorientate, distincte, cu 3 vârfuri se pot construi? Două grafuri se consideră distincte dacă matricele lor de adiacenţă sunt diferite.
* Variabila d, declarată alăturat, memorează în câmpurile a şi b lăţimea şi, respectiv, lungimea unui dreptunghi. Care dintre următoarele instrucţiuni atribuie câmpului p al variabilei d valoarea perimetrului dreptunghiului respectiv?
struct dreptunghi
{
float a,b,p;
}d;
* Se consideră o stivă în care iniţial au fost introduse, în această ordine, elementele cu valorile 1, 2 şi 3. Se notează cu AD(x) operaţia prin care se adaugă elementul cu valoarea x în vârful stivei şi cu EL operaţia prin care se elimină elementul din vârful stivei. Care sunt valorile ultimelor două elemente eliminate din stivă în urma executării secvenţei de operaţii: AD(4);EL;EL;AD(5);EL;EL?
* Utilizând metoda backtracking se generează în ordine lexicografică cuvintele de câte patru litere din mulţimea A={a,b,c,d}, cuvinte care nu conţin două vocale alăturate. Primele cinci cuvinte generate sunt, în ordine: abab, abac, abad, abba, abbb. Care este ultimul cuvânt generat?
* Pentru definiţia alăturată a subprogramului f, ce se afişează ca urmare a apelului f(125);?
void f(int n)
{ cout << n%10;
if(n!=0)
{ cout << n%10;
f(n/100);
}
}

Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile necesare sunt marcate *

Poți folosi aceste etichete HTML și atribute: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>