bacalaureat informatica varianta 1

varianta1

* Variabila x este de tip real. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul real memorat în variabila x aparţine intervalului (5,8]?
* S-a notat cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y şi cu [a] partea întreagă a numărului real a.
citeşte n (număr natural)
z<-0
p<-1
cât timp n>0 execută
c<-n%10
n<-[n/10]
dacă c%3=0 atunci
z<-z+p*(9-c)
p<-p*10
sf_daca
sf_cat_timp
scrie z
* Se consideră o coadă în care iniţial au fost introduse, în această ordine, elementele cu valorile 1 şi 2:1-2. Se notează cu AD(x) operaţia prin care se adaugă elementul cu valoarea x în coadă şi cu EL operaţia prin care se elimină un element din coadă. Câte elemente va conţine coada în urma executării secvenţei de operaţii: AD(4);EL;EL;AD(5);EL;AD(3)?
* Care este numărul maxim de componente conexe pe care le poate avea un graf neorientat cu 20 noduri şi 12 muchii?

Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile necesare sunt marcate *

Poți folosi aceste etichete HTML și atribute: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>